Problems with installing NSX Components on Hosts without correct DNS set.

Today I was encountered with a problem that took me a while to understand.

I was going to prepare a Compute Cluster with the NSX Components, vxlan and vxlan-sip vibs in NSX Manager.

The problem was that it always failed and did not want to install the vibs. The errors that were displayed are shown below.

After a closer inspection in the event logs it was saying that the hosts were unable to access the VIB Modules at the address of my NSX Manager. hmmmm, wierd!

So I started digging and tried to install the VIBs manually see Link, but still without luck of getting the job done.

I then SSH onto each of the hosts and did a NSLOOKUP, and found it strange that I did not have a DNS resolution for the NSX Manager on the ESXi-hosts.

So I went into the TCP/IP Configuration  on the hosts and noticed that an incorrect DNS IP was set on the hosts. The DNS server is 10.1.100.2 but it was set to 10.1.100.1 that is the Default Gateway address. So changed that to the correct one as shown below:

Performed a new nslookup on the hosts, that now showed the correct name for my NSX manager:

As soon as this was completed I jumped back to; NSX Installation of Components and pressed Resolve and look and behold the problem was gone and my components installed successfully. Seems that when the hosts downloads the VIBs from the NSX manager they also need to be able to resolve the name of the IP it connects to even though it goes against the IP of the NSX Manager.

That is is for this post Yaay! And don’t forget to have the DNS set correctly on your hosts!

Leave a Reply

Your email address will not be published.